MeridianMERIDIAN
Finetype

Type Registry

Browse all 251 semantic types detected by Finetype.

Types that are easy to mistake for one another are set side by side in Types told apart.

251

datetime

Dates, times, timestamps, durations, and timezone offsets89
Day of Week Nameday_of_week
VARCHARMonday
Full Month Namemonth_name
VARCHARJanuary
Periodicityperiodicity
VARCHARDaily
Calendar Yearyear
SMALLINT2024
Abbreviated Month Day Year (no comma)abbrev_month_no_comma
DATEJan 15 2024
Abbreviated Month Dateabbreviated_month
DATEJan 15, 2024
Chinese Standard Datechinese_ymd
DATE2024年1月15日
Compact Date (DDMMYYYY)compact_dmy
DATE15012024
Compact Date (MMDDYYYY)compact_mdy
DATE01152024
Compact Year-Month (YYYYMM)compact_ym
DATE202401
Compact Date (YYYYMMDD)compact_ymd
DATE20240115
DMY Date (dash-separated)dmy_dash
DATE15-01-2024
DMY Date with Abbreviated Month (dash-separated)dmy_dash_abbrev
DATE15-Jan-2024
DMY Date with Abbreviated Month (dash, 2-digit year)dmy_dash_abbrev_short
DATE15-Jan-24
DMY Date (dot-separated)dmy_dot
DATE15.01.2024
DMY Short Date (dot, 2-digit year)dmy_short_dot
DATE15.01.24
DMY Short Date (slash, 2-digit year)dmy_short_slash
DATE15/01/24
DMY Date (slash-separated)dmy_slash
DATE15/01/2024
DMY Date with Abbreviated Month (space-separated)dmy_space_abbrev
DATE15 Jan 2024
DMY Date with Full Month (space-separated)dmy_space_full
DATE15 January 2024
Full Month Day Year (no comma)full_month_no_comma
DATEJanuary 15 2024
ISO Dateiso
DATE2024-01-15
ISO Week Dateiso_week
DATE2024-W03
Japanese Imperial Year (Long/Kanji)jp_era_long
DATE令和6年1月15日
Japanese Imperial Year (Short)jp_era_short
DATER6/01/15
Julian Datejulian
DATE24-015
Korean Standard Datekorean_ymd
DATE2024년 1월 15일
Long Date with Full Month Namelong_full_month
DATEJanuary 15, 2024
MDY Date (dash-separated)mdy_dash
DATE01-15-2024
MDY Short Date (slash, 2-digit year)mdy_short_slash
DATE01/15/24
MDY Date (slash-separated)mdy_slash
DATE01/15/2024
Abbreviated Month Yearmonth_year_abbrev
DATEJan 2024
Full Month Yearmonth_year_full
DATEJanuary 2024
Month/Year (slash-separated)month_year_slash
DATE01/2024
Ordinal Dateordinal
DATE2024-015
Short Date (Day-Month-Year, 2-digit year)short_dmy
DATE15-01-24
Short Date (Month-Day-Year, 2-digit year)short_mdy
DATE01-15-24
Short Date (Year-Month-Day, 2-digit year)short_ymd
DATE24-01-15
Full Weekday with Abbreviated Monthweekday_abbreviated_month
DATEMonday, Jan 15, 2024
Weekday DMY Full (formal)weekday_dmy_full
DATEMonday, 15 January 2024
Full Weekday with Full Month Nameweekday_full_month
DATEMonday, January 15, 2024
Year-Month (ISO truncated)year_month
DATE2024-01
YMD Date (dot-separated)ymd_dot
DATE2024.01.15
YMD Date (slash-separated)ymd_slash
DATE2024/01/15
ISO 8601 Durationiso_8601
INTERVALPT30M
Unix Timestamp (microseconds)unix_microseconds
TIMESTAMP1705312200000000
Unix Timestamp (milliseconds)unix_milliseconds
TIMESTAMP1705312200000
Unix Timestamp (seconds)unix_seconds
TIMESTAMP1705312200
IANA Timezone Nameiana
VARCHARAmerica/New_York
Timezone Abbreviationtimezone_abbreviation
VARCHAREST
UTC Offsetutc
VARCHARUTC +05:00
Fiscal Yearfiscal_year
VARCHARFY2024
Calendar Quarterquarter
DATEQ1 2024
12-Hour Time (HH:MM AM/PM)hm_12h
TIME10:30 AM
24-Hour Time (HH:MM)hm_24h
TIME10:30
12-Hour Time with AM/PMhms_12h
TIME10:30:00 AM
24-Hour Time (HH:MM:SS)hms_24h
TIME10:30:00
ISO Time with Microsecondsiso
TIME10:30:00.123456
Common Log Format (Apache/Nginx)clf
TIMESTAMPTZ15/Jan/2024:14:30:00 +0000
C ctime / asctime Formatctime
TIMESTAMPMon Jan 15 14:30:00 2024
DMY Hour-Minute Datetimedmy_hm
TIMESTAMP15/01/2024 10:30
European Dot Timestamp (DMY 24h)dot_dmy_24h
TIMESTAMP15.01.2024 14:30:00
Dot YMD Timestamp (24h)dot_ymd_24h
TIMESTAMP2024.01.15 14:30:00
Unix Epoch Nanosecondsepoch_nanoseconds
TIMESTAMP1705325400000000000
ISO 8601iso_8601
TIMESTAMP2024-01-15T10:30:00Z
ISO 8601 Compactiso_8601_compact
TIMESTAMP20240115T103000
ISO 8601 with Microseconds and Offsetiso_8601_micros_offset
TIMESTAMPTZ2024-01-15T14:30:00.123456+0…
ISO 8601 with Microsecondsiso_8601_microseconds
TIMESTAMP2024-01-15T10:30:00.123456Z
ISO 8601 with Milliseconds and Offsetiso_8601_millis_offset
TIMESTAMPTZ2024-01-15T14:30:00.123+05:3…
ISO 8601 with Millisecondsiso_8601_milliseconds
TIMESTAMP2024-01-15T14:30:00.123Z
ISO 8601 with Timezone Offsetiso_8601_offset
TIMESTAMPTZ2024-01-15T10:30:00+05:00
ISO Datetime with Microseconds (no timezone)iso_microseconds
TIMESTAMP2024-01-15T10:30:00.123456
ISO Datetime with Milliseconds (no timezone)iso_milliseconds
TIMESTAMP2013-06-04T01:02:03.123
ISO Datetime, minute precision (no timezone)iso_minutes
TIMESTAMP2013-06-04T01:02
ISO Datetime, second precision (no timezone)iso_seconds
TIMESTAMP2013-06-04T01:02:03
ISO with Space Separator and Ziso_space_zulu
TIMESTAMP2024-01-15 14:30:00Z
MDY 12-Hour Datetimemdy_12h
TIMESTAMP01/15/2024 10:30 AM
MDY 24-Hour Datetimemdy_24h
TIMESTAMP01/15/2024 10:30:00
PostgreSQL Short Offsetpg_short_offset
TIMESTAMPTZ2024-01-15 14:30:00.123456-0…
RFC 2822rfc_2822
TIMESTAMPTZTue, 15 Jan 2024 10:30:00 +0…
RFC 2822 with Ordinal Indicatorsrfc_2822_ordinal
TIMESTAMPTZ15th Jan 2024 10:30:00 +0000
RFC 3339 (Space Separator)rfc_3339
TIMESTAMPTZ2024-01-15 10:30:00+00:00
Slash YMD Timestamp (24h)slash_ymd_24h
TIMESTAMP2024/01/15 14:30:00
SQL Timestamp with Microsecondssql_microseconds
TIMESTAMP2024-01-15 14:30:00.123456
SQL Timestamp with Microseconds and Offsetsql_microseconds_offset
TIMESTAMPTZ2024-01-15 14:30:00.123456+0…
SQL Timestamp with Millisecondssql_milliseconds
TIMESTAMP2024-01-15 14:30:00.123
SQL Minute-Precision Datetimesql_minutes
TIMESTAMP2024-01-15 10:30
SQL Standardsql_standard
TIMESTAMP2024-01-15 10:30:00
BSD Syslog (RFC 3164)syslog_bsd
VARCHARJan 15 14:30:00

finance

Currencies, monetary amounts, and financial identifiers29

Type Registry